Website Browse/Front Page Views Incorrect
Incident Report for npm
Resolved
This incident has been resolved.
Posted Aug 29, 2014 - 05:05 UTC
Identified
We pushed an update to the registry couchapp that triggered a view-generation cycle in our downstream CouchDB instances, unfortunately not realizing that the website was accessing the read-only replicas for this data rather than accessing the root database directly. That is, while we did wait for view generation to complete before copying the data to the production design doc, but did not wait for view generation to complete on *all* of the downstream couches.

As a result, the "Browse" pages and homepage are showing outdated and incorrect data. This problem will correct itself as the view generation completes in the read-only replicas, and the website will show accurate data shortly.

Our internal process is being updated to prevent this from happening again in the future.
Posted Aug 28, 2014 - 23:44 UTC