Elevated 503 rates in Australia
Incident Report for npm
Resolved
Network issues have been resolved. We continue to work on longer-term architectural changes to be more resilient to trans-pacific network problems.
Posted Sep 14, 2015 - 21:42 UTC
Identified
We are working with our CDN to address the issue with our Australian PoP. In the meantime, Australian users can temporarily bypass the local PoP and go directly to a US PoP by setting their hosts file to point registry.npmjs.com to 23.235.39.162 -- one of our US POP IPs. If you use this workaround, please remember to reset your hosts file once the incident is resolved, as PoP IPs change periodically.
Posted Sep 14, 2015 - 02:19 UTC
Investigating
We are seeing an elevated level of failures (503s and network timeouts) affecting users near our CDN PoP in Australia. We are actively investigating.
Posted Sep 14, 2015 - 00:19 UTC