Publish failures
Incident Report for npm
Resolved
Publications are back to normal.
Posted Feb 05, 2016 - 00:33 UTC
Monitoring
Replication has been repaired and all endpoints are now up to date with reality.
Posted Feb 05, 2016 - 00:25 UTC
Identified
There is an ongoing delay with replication of new package publishes. Publishes are successful but are not visible everywhere. Engineers are working on the issue and we will update shortly.
Posted Feb 05, 2016 - 00:15 UTC
Monitoring
Publications were failing because of a bug in our new publication flow that stacked up open connections to the registry write primary. We've rolled back to earlier code that is a little slower but doesn't leak connections while we debug the problem in our testing environment. Publications should now be succeeding.
Posted Feb 04, 2016 - 23:43 UTC
Investigating
We are investigating failing writes to the registry.
Posted Feb 04, 2016 - 23:09 UTC