Empty tarballs responses
Incident Report for npm
Resolved
Cache invalidation is complete.
Posted Sep 16, 2015 - 16:29 UTC
Monitoring
Cache invalidation is ongoing and should be complete within 15 minutes.
Posted Sep 16, 2015 - 15:55 UTC
Identified
A bug in code we rolled out to our canary server at 10:52 UTC today, and which our automated checks haven't caught caused us to return empty tarball responses to some of our users. We rolled the deployment back at 14:29 UTC and are working on invalidating caches affected by this outage.
Posted Sep 16, 2015 - 15:25 UTC