Sporadic 404s on Some Packages
Incident Report for npm
Resolved
A misconfigured machine was identified and pulled out of rotation, and 404 rates are back to normal levels as of 30 minutes ago. Our apologies.
Posted Nov 04, 2014 - 02:03 UTC
Identified
We have narrowed the elevated 404s to two CDN points of presence in south-west USA; users in this region will be most affected, with 2%-4% of traffic returning 404s right now. Our CDN partners are actively working on the issue. There is no underlying registry issue and no data loss.
Posted Nov 03, 2014 - 22:54 UTC
Investigating
Users are reporting 404 responses being served for packages that are clearly in the registry. Cause is unknown.
Posted Nov 03, 2014 - 22:03 UTC