404 Errors with Certain Packages
Incident Report for npm, Inc.
Postmortem

We've reached out to our Content Delivery Network partner and the issue was due to a misconfiguration affecting only certain regions in the world. The issue has been resolved on their end, and we needed to take no action ourselves. We confirmed the issue had been resolved by Feb 13 at 02:15 UTC.

Posted Feb 13, 2020 - 16:16 UTC

Resolved
Thanks for your patience. The issues we identified today have been resolved.
Posted Feb 13, 2020 - 03:38 UTC
Update
We are continuing to investigate this issue.
Posted Feb 13, 2020 - 00:10 UTC
Update
We're continuing to look into this issue. For most users, we're at 100% functionality. Some, unfortunately, will see 404s.
We are seeing a pattern with packages that have the word "error" in their name.
Just a reminder that we recommend using `npm ci` and not `npm i` in your automated CI/CD pipelines.
And, please, help me in thanking our engineering staff. They have delivered fast teamwork from around the world in response to your reports. We really appreciate the community feedback.
Posted Feb 13, 2020 - 00:09 UTC
Investigating
We are investigating a separate issue where some users are noticing 404's, and we're noticing different results depending on location.

It seems like this occurs on packages with `error` in their name, and varies by location.

Thank you for your patience while we investigate further.
Posted Feb 12, 2020 - 20:36 UTC
This incident affected: Package installation.