Connectivity disruption for users in certain areas
Incident Report for npm, Inc.
Resolved
Our systems are back to full operation. Local DNS issues are still lingering for some users.
Posted about 1 year ago. Oct 21, 2016 - 20:47 UTC
Update
Mitigation has significantly improved internal registry error rates. Users may still be unable to connect to npm due to DNS issues local to them.
Posted about 1 year ago. Oct 21, 2016 - 18:24 UTC
Update
For updates on how this global DNS incident is affecting our CDN, watch their status incident: https://status.fastly.com/incidents/50qkgsyvk9s4
Posted about 1 year ago. Oct 21, 2016 - 16:40 UTC
Monitoring
We have rolled out our workaround for the DDOS on our DNS provider. Error rates have dropped. Continuing to monitor to ensure that all services are working again.
Posted about 1 year ago. Oct 21, 2016 - 14:10 UTC
Update
We are acting on a plan to give ourselves backup DNS for our internal services. For more information on the DDOS that is causing this outage, you can read Dyn's status page: https://www.dynstatus.com/incidents/nlr4yrr162t8
Posted about 1 year ago. Oct 21, 2016 - 13:03 UTC
Identified
Our DNS provider is currently experiencing a DDoS. We are investigating potential solutions on our part.
Posted about 1 year ago. Oct 21, 2016 - 12:14 UTC
Investigating
We are investigating connectivity problems reported by our monitoring. We suspect that they might be disrupting service for users in certain geographical areas, but have no information about what the areas are exactly or what the root cause for disruption is.
Posted about 1 year ago. Oct 21, 2016 - 12:10 UTC