Delays in ACL & Payment Status changes
Incident Report for npm, Inc.
Resolved
The queue has caught up. Package ownership & scope payment changes should be reflected immediately.
Posted 9 months ago. Aug 23, 2017 - 03:46 UTC
Monitoring
We've rolled out a fix for the lagging queue, and are monitoring its progress. Delays are expected.
Posted 9 months ago. Aug 22, 2017 - 23:22 UTC
Identified
We have identified the slowdown as coming from an unusually high number of incoming invalidation events. The backlog is being slowly worked through, but not at an acceptable pace. We're now working on mitigations so we can process the backlog more rapidly and keep up with the incoming volume.
Posted 9 months ago. Aug 22, 2017 - 21:30 UTC
Investigating
An invalidation queue is running behind. We are investigating the root cause. Users upgrading an unpaid org or user to a paid user or org may experience errors when accessing existing private packages. New private packages are unaffected. Adding or removing maintainers from a package will not be reflected in "npm owner ls".
Posted 9 months ago. Aug 22, 2017 - 19:30 UTC