Expected unavailability due to AWS reboots
Incident Report for npm, Inc.
All short-notice AWS instance restarts have completed and registry services are back to normal.
Posted 3 months ago. Jan 04, 2018 - 22:33 UTC
Due to new findings related to the security issue resulting in AWS needing to schedule maintenance reboots, AWS has decided to act on the scheduled maintenance reboots as soon as possible and will be executing them starting at 12:00 AM UTC. While we've planned to work around the reboots, AWS will now be taking out critical parts of our infrastructure in both regions at the same time. We don't yet have an estimate on the extend of the unavailability.
Posted 3 months ago. Jan 04, 2018 - 00:09 UTC