website not responding
Incident Report for npm, Inc.
Resolved
All services back to normal.
Posted 10 months ago. Jan 05, 2017 - 05:23 UTC
Monitoring
We have successfully failed over to our secondary & removed the temporary workaround.
Posted 10 months ago. Jan 05, 2017 - 04:51 UTC
Identified
We indeed lost a database primary host. We are failing over to the secondary now. In the meantime, we've deployed a workaround that restores website functionality, albeit with no billing data. The website will temporarily report placeholder billing data; this workaround will be backed out shortly.
Posted 10 months ago. Jan 05, 2017 - 04:32 UTC
Investigating
Our website is not responding to requests right now. An instance providing a backing service has gone down. We are in the process of restarting and/or replacing the downed host.
Posted 10 months ago. Jan 05, 2017 - 04:24 UTC