404 Errors when Installing Certain Packages
Incident Report for npm
Resolved
Our team has finished fixing the metadata permissions issue on the remaining packages. We're seeing that has resolved the issue. Thanks for your patience.
Posted Feb 12, 2020 - 19:25 UTC
Update
Some package metadata for a select few public packages was stored with incorrect permissions (too restrictive.)
We're fixing them, purging the incorrect 404's from the cache, and you should see positive results very soon.

A bit of detail: We've found this problem is only occurring with minified package metadata. The npm client automatically falls back to fetching the full package metadata when that's not available.

For other use cases: our developers are working to restore full functionality at this time. Thanks for your patience.
Posted Feb 12, 2020 - 17:54 UTC
Identified
We've found some further issues that are causing disruption of service to select geographic regions, for some select packages. We are currently implementing more fixes to restore 100% functionality to all regions.
Posted Feb 12, 2020 - 17:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 12, 2020 - 13:37 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 12, 2020 - 13:17 UTC
Monitoring
We believe we have identified the current issue with 404 errors on specific packages in specific world regions, and a fix has been applied.

It will take some time to propagate across all our nodes and CDN layer.
We will keep this incident open until the issue has fully propagated.
Posted Feb 12, 2020 - 13:10 UTC
Investigating
We are currently investigating issues with installing certain packages.

Some of the packages known to be affected are: 3d-view, error-ex ,42-cent-base, 8base-cli.
Posted Feb 12, 2020 - 13:04 UTC
This incident affected: Package installation.