415 errors when publishing some packages
Incident Report for npm, Inc.
Resolved
Publications are working again.
Posted 4 months ago. Feb 07, 2018 - 00:30 UTC
Monitoring
We believe publication is now working as expected.
Posted 4 months ago. Feb 07, 2018 - 00:16 UTC
Update
We have pushed a fix for package publications that appear to succeed but don't result in an updated package.
Posted 4 months ago. Feb 07, 2018 - 00:02 UTC
Update
The 415 error rate has dropped, revealing another bug in publication introduced in the same code push. The team is continuing to mitigate.
Posted 4 months ago. Feb 06, 2018 - 23:53 UTC
Update
Packages over a certain size are being blocked from publication, causing the 415 errors some package publishers are seeing. We have identified where this unintended limit is being enforced, and are rolling out a fix now.
Posted 4 months ago. Feb 06, 2018 - 23:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Feb 06, 2018 - 23:39 UTC