Partial outage of scoped package reads
Incident Report for npm, Inc.
Resolved
The APIs remain stable and all systems are back to normal. We're resolving this incident.
Posted 10 months ago. Sep 20, 2018 - 00:56 UTC
Monitoring
We have identified a configuration error responsible for the overload and rectified it. Package pages and scoped package reads appear to be back to normal. We are closely monitoring the situation.
Posted 10 months ago. Sep 20, 2018 - 00:21 UTC
Update
We have partially restored the website, so you can read package READMEs again, and access to scoped packages is slow but restored. We are working on a more permanent solution.
Posted 10 months ago. Sep 20, 2018 - 00:05 UTC
Update
Our API that checks for whether a package is private or not is overloaded; this is leading to scoped packages being unavailable. No data has been lost and we are working on restoring the API. We apologize for the inconvenience.
Posted 10 months ago. Sep 19, 2018 - 23:39 UTC
Update
Website package pages are also affected.
Posted 10 months ago. Sep 19, 2018 - 23:17 UTC
Identified
The registry is experiencing a partial outage for scoped package reads: users will see intermittent timeouts and 503 responses. We are working on a fix.
Posted 10 months ago. Sep 19, 2018 - 22:40 UTC
This incident affected: Registry Reads and Website Reads.