Errors unpublishing packages
Incident Report for npm, Inc.
Resolved
The issue with failures on requests to unpublish packages within the initially permitted 72-hour window is now resolved.
Posted about 1 month ago. Aug 17, 2018 - 00:25 UTC
Monitoring
We've applied a fix for unpublish errors during the unpublish window.
Posted about 1 month ago. Aug 16, 2018 - 21:04 UTC
Update
We have narrowed this down even further to a failing elasticsearch query and are working on a fix.
Posted about 1 month ago. Aug 16, 2018 - 14:43 UTC
Identified
We are aware that a large proportion of requests to unpublish packages within the initially permitted 72 hour window are erroring with a generic HTTP 500 error.

This is due to an internal service request timing out when authenticating the unpublish requests, and is not affecting any parts of the package publishing workflow, and we are working on a fix.
Posted about 1 month ago. Aug 16, 2018 - 00:47 UTC