replication lag on publications
Incident Report for npm, Inc.
Resolved
Everything looks clear.
Posted 2 months ago. Mar 25, 2017 - 03:31 UTC
Monitoring
The bug that was causing too many couchdb document updates has been fixed, and changes should now be flowing through the system at a normal rate again. We're monitoring to make sure the backlog drains as expected.
Posted 2 months ago. Mar 24, 2017 - 23:17 UTC
Identified
We've identified the root cause of the replication delays. Publications have been accepted & stored, but replication on our CouchDB instances is behind because of unexpected load caused by a bug elsewhere that creates many document updates when certain package data is changed. We're working on a fix.
Posted 2 months ago. Mar 24, 2017 - 21:18 UTC
Investigating
We are investigating lag on replicating publications to our leaf nodes as well as downstream to registry mirrors.
Posted 2 months ago. Mar 24, 2017 - 20:28 UTC