DNS misconfiguration cached in ISP DNS caches
Incident Report for npm, Inc.
Resolved
Global DNS caches are now reporting correct records and we have seen a return to normal incoming traffic levels.

If you are still seeing DNS, SSL or other network related issues please get in touch through our support channels.
Posted 3 months ago. Sep 02, 2018 - 12:26 UTC
Update
This has now been resolved for most users and we will continue to monitor until it has cleared for everyone.
Posted 3 months ago. Sep 01, 2018 - 17:13 UTC
Update
Some users are having trouble accessing npm registry services, or receive certificate errors, because of issues connected to an earlier DNS migration. We have updated nameserver (NS) settings in a way that should address this for all users by 15:30 UTC (3:30 pm California time), and we continue to monitor the situation.

More detail: npm’s primary DNS provider has been returning erroneous nameserver (NS) entries that point to our legacy DNS provider, which served an outdated zone file. This caused resolvers to round-robin between valid and invalid results leading to DNS, registry, and SSL certificate errors for our end users. We have updated NS entries on both our new and legacy DNS providers with valid entries.
Posted 3 months ago. Sep 01, 2018 - 15:34 UTC
Update
We are continuing to monitor the outage as more ISP DNS caches clear.
Posted 3 months ago. Sep 01, 2018 - 08:02 UTC
Update
We are continuing to monitor for any further issues.

Out of a random selection of ~300 global ISP nameservers, 8 returned "not found" results for npmjs.com, which puts us right on track for all caches to have cleared with the correct results by tomorrow.

We will continue to monitor the situation over the weekend.
Posted 3 months ago. Aug 31, 2018 - 20:42 UTC
Update
Update - An alternative to using a different public DNS provider (like Google or CloudFlare) is to look up an IP address for www.npmjs.com and add it to your hosts file:

1. To look up an IP for www.npmjs.com, either use Google Public DNS or the command line with `dig` and CloudFlare's DNS:

dig www.npmjs.com @1.1.1.1


2. Add the IP address to your /etc/hosts file.


Please note: to avoid issues if the resolved IP address changes, we strongly advise that you remove this entry from your hosts file after the weekend.
Posted 3 months ago. Aug 31, 2018 - 17:20 UTC
Update
We continue to monitor an earlier outage involving a DNS misconfiguration has lead to some ISPs caching npmjs.com as missing, a workaround for this is to use a third party DNS provider such as Cloudflare or Google, the affected caches should clear within the next 24 hours.

If you are using registry.npmjs.com as your registry endpoint, pointing to registry.npmjs.org (the default) should resolve this issue for the time being.
Posted 3 months ago. Aug 31, 2018 - 17:10 UTC
Monitoring

An earlier outage involving a DNS misconfiguration has lead to some ISPs caching npmjs.com as missing, a workaround for this is to use a third party DNS provider such as Cloudflare or Google, the affected caches should clear within the next 24 hours.

If you are using registry.npmjs.com as your registry endpoint, pointing to registry.npmjs.org (the default) should resolve this issue for the time being.
Posted 3 months ago. Aug 31, 2018 - 15:35 UTC
This incident affected: Registry Reads, Website Reads, and www.