Degraded performance while installing packages

Incident Report for npm

Resolved

This incident has been resolved.
Posted Jul 28, 2023 - 18:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2023 - 13:15 UTC

Update

After a series of attempts to mitigate the issue with reduced success, we are continuing to investigate and working with our providers on what could be the root cause of this incident.
Posted Jul 26, 2023 - 13:41 UTC

Investigating

We are currently investigating an increase in latency observed when installing packages.
Posted Jul 25, 2023 - 13:29 UTC
This incident affected: Package installation.